Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19
  1. #11
    Join Date
    Apr 2013
    Location
    KC, MO
    Posts
    686

    Default

    Quote Originally Posted by blaze5012 View Post
    Sounds like I have my answer, thanks for all the replies.

    I didnt believe any of you, but it was the poo example that finally got me to take the hint...
    Glad we could help.

    If you have Prime, you can get a blower fan real quick.

    http://www.amazon.com/Attwood-Quiet-...ds=boat+blower
    -Mike
    2006 Supra Sunsport 20V

  2. #12
    Join Date
    Apr 2012
    Location
    Tacoma, Wa
    Posts
    862

    Default

    20 year of doing smoke evacs from houses and a little physics.
    2003 Supra Launch 22SSV
    1986 Ski Natique 2001

  3. #13
    Join Date
    Feb 2012
    Location
    Ohio
    Posts
    828

    Default

    Where are you located that you are still getting to take your boat out?
    2006 24SSV 8.1 Vortec

  4. #14
    Join Date
    Dec 2013
    Posts
    543

    Default

    Old thread...but applies to me!

    My blower on my 2005 SSV24 has died. Sooo...where exactly is it to replace?? I always assumed it was in the engine bay, but I cannot find it there. Since it is not making noise I can't track it down.

  5. #15
    Join Date
    Jun 2012
    Location
    Knoxville TN
    Posts
    896

    Default

    Probably looks like this:

    https://www.amazon.com/attwood-Blowe.../dp/B07PX4RGR6

    Your vent probably leaves the boat from out of the top of the transom (middle section) OR you will see a side vent on your top boat.
    You should see the black flex hose when you open the engine hatch.

    Location - probably under the motor, look by the spark plugs from sitting in the back locker.

    Sent from my P00I using Tapatalk
    Last edited by MJHKnox; 06-04-2019 at 08:51 AM.
    2007 Supra SSV 22'

  6. #16
    Join Date
    Dec 2013
    Posts
    543

    Default

    Thanks...that helps. I saw the blower but thought it was just a hose support. That also explains why it died. We filled the bilge with water after a ballast hose blew. I think I’ll move it higher up when I replace it.

    Thx again!

  7. #17
    Join Date
    Jun 2012
    Location
    Knoxville TN
    Posts
    896

    Default

    Quote Originally Posted by CJD View Post
    Thanks...that helps. I saw the blower but thought it was just a hose support. That also explains why it died. We filled the bilge with water after a ballast hose blew. I think I’ll move it higher up when I replace it.

    Thx again!
    Use a meter to see if you are getting power back there with the switch on - at the blower. It's probably connected to fuse under the dash, check that.

    Probably right, if the blower motor was underwater, it might not have survived.
    Last edited by MJHKnox; 06-04-2019 at 09:00 AM.
    2007 Supra SSV 22'

  8. #18
    Join Date
    Dec 2013
    Posts
    543

    Default

    Yep, the dunking killed it, as it was frozen solid. I was surprised to find that the boat only has a single motor, instead of 2 mentioned earlier in this thread.

    Anyway, thanks again!

  9. #19
    Join Date
    Jun 2012
    Location
    Knoxville TN
    Posts
    896

    Default

    Quote Originally Posted by CJD View Post
    Yep, the dunking killed it, as it was frozen solid. I was surprised to find that the boat only has a single motor, instead of 2 mentioned earlier in this thread.

    Anyway, thanks again!
    Good deal. I think my 2007 only has one. I need to look next time Iím crawling around in there.


    Sent from my iPhone using Tapatalk
    2007 Supra SSV 22'

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •