Results 1 to 7 of 7
  1. #1
    Join Date
    May 2016
    Posts
    15

    Default bags won't fill or empty

    I have a 2006 supra launch 24ssv and the bags stopped filling and emptying while I was using them, the light's work for the center and starboard but not the port side. any ideas.
    Michael

  2. #2
    Join Date
    May 2016
    Posts
    15

    Default bags won't fill or empty

    I have a 2006 supra launch 24 SSV and the bags stopped filling and emptying while I was using them, checked the power there is none but the light's work for the center and starboard side but not the port side.
    Michael Y.

  3. #3

    Default

    Probably popped the breaker under the cockpit. Hard to see under there but sometimes my switches that control my bags will stop working and then when I reset the breaker it works perfectly again

  4. #4
    Join Date
    May 2016
    Posts
    15

    Default

    I am a mechanic, pushing breaker was the first thing.

  5. #5
    Join Date
    Apr 2015
    Location
    Houston, TX
    Posts
    52

    Default

    Did the impeller burn out?

    Sent from my SM-G930V using Tapatalk

  6. #6

    Default

    Are you saying all bags stopped working or just the port side?

  7. #7
    Join Date
    Oct 2008
    Location
    Northern Colorado
    Posts
    1,596

    Default

    Hey Michael, welcome to the forum. There is no need to post the same question in multiple forums -- one place only please!

    Todd
    2008 24 SSV, Gravity Games Edition.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •