Results 1 to 9 of 9

Thread: Pirata missing

  1. #1
    Join Date
    Sep 2011
    Location
    Michigan, Mullett Lake
    Posts
    7

    Default Pirata missing

    Owner of an 87 Pirata. Overall the boat has been great, until this year. A number of issues have kept us off the water most of the summer and I think I have solved all issues until this new one popped up.
    Boat fires right up, runs great for 15-20 minutes. We usually at this point set up to ski/board etc and at this point I can few it start to bog, caugh, miss and eventually stall out. I can usually get it started again but it acts like it is running really rich and again chokes itself out.
    If I let it sit for 30 minutes it starts right back up like there wasnít an issue.
    PCM 454, crab rebuilt last year, new fuel lines, thermostat, water pump impeller, this year, distributor two years ago.
    Any ideas would be very appreciated heading into our last week of summer here in northern Michigan.

  2. #2

    Default

    Are you sure itís a fuel issue at that point? What are you running for your ignition system? Iíd take a serious look at those components as well. I had a similar issue that took a while longer to rear itís head, about 2 hours, but it acted the same and ended up being my starter solenoid. Would soak the heat for a while and then open the circuit for the ignition. Next time you take it out and it does it make sure you have the tools to do it and pull a plug and check to make sure you have spark. If you donít have spark or itís a really weak spark then itís ignition related. Sometimes coils will act exactly like your boat is when they start to go bad


    Sent from my iPhone using Tapatalk
    2008 Sunsport 22v

  3. #3
    Join Date
    Sep 2011
    Location
    Michigan, Mullett Lake
    Posts
    7

    Default

    My guess was somewhere in the ignition system but I am unsure where to start that search. Any telltales that might link it to a solenoid, coil, etc?

  4. #4

    Default

    When you fire it up after waiting the 30 minutes or so does it continue to do the same thing repeatedly? Do you know if you still have points?


    Sent from my iPhone using Tapatalk
    2008 Sunsport 22v

  5. #5
    Join Date
    Sep 2011
    Location
    Michigan, Mullett Lake
    Posts
    7

    Default

    Quote Originally Posted by Creekrat View Post
    When you fire it up after waiting the 30 minutes or so does it continue to do the same thing repeatedly? Do you know if you still have points?


    Sent from my iPhone using Tapatalk
    Yes on points. When I have used the boat since the issue started, I would start the boat, run it over to my parents cottage (15-20 minutes) shut down (5-20 minutes) to load other family members up and head out from there. Usually would start acting up in the first 10 minutes or so.

  6. #6

    Default

    My guess would be coil or issue with the points. Possibly the condenser. Coils are pretty cheap at around $40 or so. I upgraded a mastercraft with the pertronix electronic ignition and coil for right at $100


    Sent from my iPhone using Tapatalk
    2008 Sunsport 22v

  7. #7
    Join Date
    Sep 2011
    Location
    Michigan, Mullett Lake
    Posts
    7

    Default

    Quote Originally Posted by Creekrat View Post
    My guess would be coil or issue with the points. Possibly the condenser. Coils are pretty cheap at around $40 or so. I upgraded a mastercraft with the pertronix electronic ignition and coil for right at $100


    Sent from my iPhone using Tapatalk
    Do you know where I can find that information for. My set-up? I would be interested in changing it over for sure.

  8. #8

    Default

    Skidim should be able to set you straight. I ordered mine off of amazon. You could also try calling pertronix themselves and asking which part number you need


    Sent from my iPhone using Tapatalk
    2008 Sunsport 22v

  9. #9
    Join Date
    Jul 2018
    Location
    Lafayette In.
    Posts
    61

    Default

    What Carb are you running? Pull a Spark plug and see if its running rich. it will be very, vary black if it is rich. When you say cough is it back firing? Is the chock on when its running good? Does it fall off when the chock kicks off? The electronic ignition is always a good up grade !!!!!!!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •