Results 1 to 4 of 4
  1. #1

    Default 1989 supra shuts down and wont run after 30 min of operation?????

    So after i run the boat for 20 to 30 min. It develops a miss onvthe top end and will get worse as i continue to run the supra until it dies. It will strt the next day and do the same thing all over again...for the first 30 min the boat performs very well...no misses ect. Ive installed an electronic ignition and it is getting spark...new coil too...there is gas flowing into the carb..i installed a new fuel pump.... the plugs r new ...so there is fuel and fire ....help...!

  2. #2

    Default

    Does your breaker switch? I had mine go bad last year.


    Sent from my iPhone using Tapatalk

  3. #3
    Join Date
    Feb 2004
    Location
    Northwest Missouri, St. Joseph
    Posts
    82

    Default

    Check the carb to see if there is actually fuel there, look down into the bores while the engine is running, pump the throttle and you should see fuel squirt into the carb. If the fuel lines are original you could have a collapsed line. Or maybe some trash in the tank covering the pick-up.
    agetech
    89 Comp
    Restored to "Better than New"

  4. #4
    Join Date
    May 2019
    Location
    Arizona
    Posts
    53

    Default

    Garbage in the fuel tank and clogged fuel filter. Everything settles when it sits until you get fuel flowing again.


    Sent from my iPhone using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •