Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Join Date
    Oct 2019
    Posts
    26

    Default 351W PleasureCraft overheating...

    First, thanks to all who contributed advice as I rebuilt an ‘86 over the winter. It runs well. However, I have a new problem.
    The engine overheats soon after cranking. I replaced the impeller and belts and the pump is turning on the spindle.
    Anyone tell me what else the problem could be?
    Is it possible I re-mounted the pump backward or does it matter?
    Many thanks in advance.
    Tony M

  2. #2

    Default

    New/functioning thermostat? Do you know the sender and gauge are good?is this sitting in the water or on the hose?

    Sent from my SM-N950U using Tapatalk

  3. #3
    Join Date
    Jul 2007
    Location
    Flowery Branch Georgia
    Posts
    2,501

    Default

    Make sure you mounted the raw water pump with the hoses lining up on the engine side. Are you getting water out of the exhaust?

  4. #4
    Join Date
    Oct 2019
    Posts
    26

    Default

    Ok. Thanks. I’ll check both.
    Where is thermostat located?

  5. #5
    Join Date
    Dec 2015
    Location
    Lake Nottely, Blairsville, GA
    Posts
    789

    Default

    Front of the motor, look for where three 1" hoses come out of it. A 2" hose from raw water pump comes in below. Sits in front of distributor slightly off to left. Should see 2 Allen wrench type bolts.

    2012 Supra Sunsport 242
    1991 Supra Comp ts6m
    1983 Supra Rider aka Mischief IV

  6. #6

    Default

    If it wasn't new then take it out and put it in a pot of water on the stove. Measure the temperature of the water when you see the thermostat start opening to verify it's working correctly. Verify the temperature at which it is in full open position.

    Sent from my SM-N950U using Tapatalk

  7. #7
    Join Date
    Jul 2007
    Location
    Flowery Branch Georgia
    Posts
    2,501

    Default

    post a pic of how your raw water pump is mounted now

  8. #8
    Join Date
    Oct 2019
    Posts
    26

    Default

    Tried 30 mins to figure out how to send a pic to no avail. I’ll report back later. Thanks for hanging in there with me.

  9. #9
    Join Date
    Jul 2007
    Location
    Flowery Branch Georgia
    Posts
    2,501

    Default

    I post pics to Imgur then copy and paste here. Text me the pic 678-227-8833

  10. #10
    Join Date
    Apr 2002
    Location
    Florence, AL
    Posts
    773

    Default

    Water pump likely on backwards. It goes on the opposite direction it seems like it should.
    1992 Supra Mariah - Red
    PCM 351HO 285hp - PCM 1.23:1 Transmission
    OJ XMP 4 Blade CNC 13x15.5RH

    "People do weird things to boats" -Unknown

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •