Page 1 of 3 123 LastLast
Results 1 to 10 of 26
  1. #1

    Default Can't seem to idle right this spring-1984 Comp

    Another year with the 1984 Comp that Michael Hunter restored. Had a good year last year. Not so good this year.

    The boat was not very interested in starting coming out of winterization. Took quite a bit of cranking and then quite a bit of warming up before it would finally run at idle on the hose. Stabil was put in a full tank of gas when I winterized in October and fogging oil used on the carb.

    I finally thought i had the idle doing well enough so we took it out saturday. Boat would idle ok for a minute and then it would get worse after a couple minutes of idling. I played with the idle air mixture screws throughout the day and never could get it right. Even tried bumping up the idle speed a little. By the end of the day, it idled OK buy soon as you put it in gear would shut off. Boat seemed to run A-OK outside of idle speed.

    At this point, I'm thinking i'm probably due for a carb rebuild. I had similar issues to this last year our of winterization but was able to adjust the idle air mixture and it worked out.

    Anything else I should check before the carb rebuild? Any good DIYs for said carb rebuild? Planning to order the kit from SkiDim.

  2. #2
    Join Date
    Jun 2010
    Location
    Oregon
    Posts
    285

    Default

    Try a new PCV valve

  3. #3
    Join Date
    Jul 2007
    Location
    Flowery Branch Georgia
    Posts
    2,458

    Default

    How much old gas is in it. Sounds like bad gas?

  4. #4

    Default

    Quote Originally Posted by michael hunter View Post
    How much old gas is in it. Sounds like bad gas?
    Full Tank with Stabil from October. Taking it to the shop tomorrow.

  5. #5
    Join Date
    Jun 2010
    Location
    Oregon
    Posts
    285

    Default

    I had trouble with the PCV valve bad idle. There only about 5 bucks.

  6. #6
    Join Date
    Apr 2012
    Posts
    223

    Default

    Sounds like a dirty carb. May not really need a rebuild but moreover just a thorough cleaning

    Sent from my SM-G920V using Tapatalk

  7. #7
    Join Date
    Jul 2010
    Location
    N.W. Suburbs Chicago, IL
    Posts
    2,223

    Default

    Also in the fall when you lay it up next time, I would advise against fogging the carb and instead fog the cylinders independently. I have never fogged the carb on mine and it fires up every spring on the first attempt every time and idles.
    '86 Comp TS6M - Reborn 2016
    Riding Connelly Skis

  8. #8

    Default

    Quote Originally Posted by Jetlink View Post
    Also in the fall when you lay it up next time, I would advise against fogging the carb and instead fog the cylinders independently. I have never fogged the carb on mine and it fires up every spring on the first attempt every time and idles.
    I'm thinking the same thing. I didn't fog the carb the year before and it started up much easier, I'm thinking that the fogging oil probably just gummed it up.

  9. #9

    Default

    Just got a call from the shop. Sounds like there was a kink the metal fuel line (Probably caused by myself when I tightened it at the carb). They also said the cap and rotor were very corroded and the plugs needed changed. I'll get all that fixed and then I asked them to tune up the carb while they were at it just since i had been messing with it and i'm sure it's not 100% right.

  10. #10

    Default

    Got the boat back last monday. They replaced the fuel line, new cap and rotor, plugs, adjusted timing. Started it up on the hose in the driveway and it started right up with a smooth idle. Took it to the lake on Friday for a shake down run and it idles well, but is missing as you increase RPM out of idle which it's never done before. Between 3-4000 RPM it's bad enough that you can watch the tach drop a few hundred RPM. Needless to say, it's going back in today as it's never done this before. I'm guessing the timing is off somehow? Not really sure.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •