Results 1 to 2 of 2
  1. #1

    Question Rear hard ballast not filling

    I need some help. My back right (looking back from the drivers seat) ballast is not filling. Both others fill. I hear the pump on when switch is turned on. This is the gravity ballast on the 2006 Supra Launch 21v with the inboard motor. I canít seem to find the pumps to even check the impellers since that is what people have been telling me is more than likely the issue. Can anyone help?
    2006 Supra Launch 21v

  2. #2
    Join Date
    Jun 2012
    Location
    Knoxville TN
    Posts
    1,415

    Default

    Quote Originally Posted by cutterpack_07 View Post
    I need some help. My back right (looking back from the drivers seat) ballast is not filling. Both others fill. I hear the pump on when switch is turned on. This is the gravity ballast on the 2006 Supra Launch 21v with the inboard motor. I can’t seem to find the pumps to even check the impellers since that is what people have been telling me is more than likely the issue. Can anyone help?
    Not aware the 2006 has hard ballast tanks.

    I assume you would have one ballast bag in each locker and one in the center.

    If you have the original sprinkler valve system, you will have a 1 pump that directs the water to a manifold. The pump is usually to the side of the transmission and vdrive. The manifold has orbit values that direct water to FILL the bags. When you drain, there is a separate rule pump, one for each bag, that is typically found at the back of the bag. No impellers on this type of system. Old school and slow.

    If something has been modified on your boat, you would have to give more information or post pics. For example, if someone installed reversible pumps on the setup.
    2018 Supra SL400

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •