Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    Join Date
    Jun 2020
    Posts
    8

    Default 1986 supra 351W BAD miss under load after warm up

    so ive pretty much had this problem for a year now. Once the boat warms up if i put a heavy load it starts to miss really bad but it will kinda clear up after i cruise under little load. yesterday i adjusted the timing and did like 20 out the hole digs and it ran great and only had a very small slight miss so i thought i had it. Here are the things ive done
    New cap and rotor
    new spark plugs
    chaeck timing around 6-8 degs
    new water separator filteri have a mallory electric ignition and distributor

    also what are the best spark plug wires

    thanks

  2. #2
    Join Date
    Jul 2010
    Location
    N.W. Suburbs Chicago, IL
    Posts
    2,232

    Default

    Check your ignition coil, mine went bad and I spent a significant amount of time chasing all sorts of issues that resolved with the new coil.
    '86 Comp TS6M - Reborn 2016
    Riding Connelly Skis

  3. #3
    Join Date
    Jul 2007
    Location
    Flowery Branch Georgia
    Posts
    2,500

    Default

    Are you still running points?

  4. #4
    Join Date
    Jun 2020
    Posts
    8

    Default

    No it’s all electronic

  5. #5

    Default

    Quote Originally Posted by Jetlink View Post
    Check your ignition coil, mine went bad and I spent a significant amount of time chasing all sorts of issues that resolved with the new coil.
    Good place to start. Also, has the carburetor ever been rebuilt?

  6. #6
    Join Date
    Jun 2020
    Posts
    8

    Default

    Carb is new just picked up a coil and a fuel pressure gauge bout to slap that on there. What about plug wires what are best?

  7. #7

    Default

    Quote Originally Posted by bonomosupra View Post
    Carb is new just picked up a coil and a fuel pressure gauge bout to slap that on there. What about plug wires what are best?
    I used the standard PCM wires all the years I had my 89'. Never had an issue. On my current boat, I bought a set of Standard Blue streak ignition wires from Rock Auto. These were a step up from the stock Indmar wires.

  8. #8
    Join Date
    Jun 2020
    Posts
    8

    Default

    Can you get them from a auto parts store? If so do you have a vehicle to reference for them?

  9. #9

    Default

    Quote Originally Posted by bonomosupra View Post
    Can you get them from a auto parts store? If so do you have a vehicle to reference for them?
    I donít have the info anymore on my 89í. My 2004 takes different wires.

  10. #10
    Join Date
    Jul 2007
    Location
    Flowery Branch Georgia
    Posts
    2,500

    Default

    What electronic ignition brand are you running ? Some of the electronic conversion system were problematic.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •