Results 1 to 2 of 2
  1. #1
    Join Date
    Aug 2019
    Location
    St. Louis , MO
    Posts
    134

    Default LOOSE STEERING 2004 Launch SS DD

    Well I worked on my steering on Saturday to try and fix some issues. First, when you would turn fully hard left, it would seem to bind when trying to straighten it out. I noticed that tiller arm was almost straight in line with the cable, so I adjusted the tube and greased the ball pivot and rudder post.
    Took it our Sunday and its really fishtailing(wandering). I've read all the threads about the link at the end of the cable to tiller arm connection, and noticed there is some slop there. I am going to dismantle my tilt steering tonight and check for loose bolts, and also check the pinion to rack engagement. The cable moves smoothly in both directions with no binding now. I've noticed from day one, that the steering is loose compared to my 89'. It was smooth and tracked great. Had it 24 years and never a problem.

  2. #2
    Join Date
    Aug 2019
    Location
    St. Louis , MO
    Posts
    134

    Default Loose steering

    Quote Originally Posted by secondsupra2004 View Post
    Well I worked on my steering on Saturday to try and fix some issues. First, when you would turn fully hard left, it would seem to bind when trying to straighten it out. I noticed that tiller arm was almost straight in line with the cable, so I adjusted the tube and greased the ball pivot and rudder post.
    Took it our Sunday and its really fishtailing(wandering). I've read all the threads about the link at the end of the cable to tiller arm connection, and noticed there is some slop there. I am going to dismantle my tilt steering tonight and check for loose bolts, and also check the pinion to rack engagement. The cable moves smoothly in both directions with no binding now. I've noticed from day one, that the steering is loose compared to my 89'. It was smooth and tracked great. Had it 24 years and never a problem.
    Update:
    Made a new cable to tiller arm link at my shop out of a Stainless Steel blank. Also found the pinch bolt on the tiller arm to rudder was loose. Turned it 3 full turns before it tightened up. Checked the rack to pinion backlash at its pretty tight. Took it out yesterday and it steers like a different boat. All good.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •