Page 6 of 6 FirstFirst ... 456
Results 51 to 57 of 57
  1. #51
    Join Date
    Mar 2021
    Posts
    20

    Default

    Quote Originally Posted by h2o-ski View Post
    Hey MySupra,

    Looks like the forum downsized the image and is too blurry to read. Going to PM you my email to see if email is any better.

    h20-ski:

    I sent the 1990 Manual and undated PCM service manual to your email address.

    MySupra

  2. #52
    Join Date
    Jan 2020
    Location
    Central Texas
    Posts
    59

    Default

    Quote Originally Posted by MySupra View Post
    h20-ski:

    I sent the 1990 Manual and undated PCM service manual to your email address.

    MySupra
    Email has been received. Much appreciated. I have since found a few service manuals and such but not a lot of good schematics

  3. #53
    Join Date
    Jan 2020
    Location
    Central Texas
    Posts
    59

    Default

    Update time

    Thanks to the wiring diagrams and a little luck. I got the SBC running. Considering the amount of rust in two cylinders it runs pretty good, though one cylinder is down on compression. A local repair shop does have a reman in stock that he is willing to give me a good deal on in case this one doesn't hold.

    I got the engine in the boat but I am struggling getting the engine aligned with the prop shaft. Doesn't help that the rubber bushings are a little tight.

    Also does anyone have a source for where I can find a replacement rub rail insert? All I seem to find is from Taco and their inserts are different shapes than what I have.
    Last edited by h2o-ski; 12-14-2022 at 01:04 PM.

  4. #54
    Join Date
    Jan 2020
    Location
    Central Texas
    Posts
    59

    Default

    I had another go at the alignment. Not sure what I was thinking before but I had everything reversed. The trans mounts were topped out and the engine mounts were bottomed out.

    Now that I got the mounts fixed, I just have to get the crankshaft axis and prop shaft inline.

  5. #55
    Join Date
    Jan 2020
    Location
    Central Texas
    Posts
    59

    Default

    Engine is aligned . I got a few goodies for Christmas, namely fuel pump, relays and some other bits and pieces. I have been working on wiring. The old wiring had strange routing and some of my modifications obsoleted other parts.

    I got most of the front floor and stringers repaired. Just waiting for some warmer weather to finish putting the repairs to bed.

    The struggles right now are how can I route the trans cooler. The lines are not that long and my plan is to have the cooler post sea strainer. I may end up buying longer lines to run to the cooler towards the front of the engine. I also broke my throttle cable trying to get the rusted end off. Hopefully there is still enough thread at the end to work.

  6. #56
    Join Date
    Dec 2015
    Location
    Lake Nottely, Blairsville, GA
    Posts
    1,226

    Default

    Coming along nicely...looking good. Engine back in is a big step. If they're 40 year old hoses, may want to replace anyways. My 2 cents.

    1983 Supra Rider aka Mischief IV
    1983 Supra Beast
    1985 Supra Rider
    1986 Supra Sunsport Skier
    1987 Supra Marauder
    1991 Supra Comp ts6m
    2012 Supra Sunsport 242

  7. #57
    Join Date
    Jan 2020
    Location
    Central Texas
    Posts
    59

    Default

    Quote Originally Posted by Mischief IV View Post
    Coming along nicely...looking good. Engine back in is a big step. If they're 40 year old hoses, may want to replace anyways. My 2 cents.
    Indeed, I found some 42" hoses on SkiDIM that would work perfectly to get the cooler in front of the engine and below the trans oil sump. According to the Borg-Warner service manual the cooler is supposed to be at sump level to prevent drain back.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •