Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2021
    Posts
    2

    Default Blower won’t turn on?

    Hello all,

    I recently bought an 07’ Supra Sunsport 22v, the “check engine light” came on and I told it in to have it addressed, it has been resolved but now my blower won’t turn on...could the circuit breaker have been tripped? Is resetting it easy?

    Help?
    Thanks

  2. #2
    Join Date
    Dec 2013
    Posts
    600

    Default

    There is a large, 40amp breaker, normally forward of the engine that could have tripped. That one can be reset. The other circuits are fuses, usually located under the dash...and those must be replaced if they blow.

    When my blower went out it was because we took a lot of water one trip and the blower motor is located at the bottom of the bilge. Once it gets dunked it dies and must be replaced. They are cheap and available at most boat dealers.

  3. #3
    Join Date
    Jun 2012
    Location
    Knoxville TN
    Posts
    1,259

    Default

    First, I'm pretty sure there is a breaker under the dash. Push to reset.

    Second, If you have a multimeter, you can check to see if you are getting power at the fan when the blower switch is on. It's easy to get to. It should work with the key in the ON or OFF position.

    Might be the switch, that can also be checked with a multimeter. That would be rare, but I would check for loose wires to the switch.

    As mentioned above, the fans can go bad.


    Sent from my P00I using Tapatalk
    Last edited by MJHKnox; 03-22-2021 at 10:22 PM.
    2018 Supra SL400

  4. #4
    Join Date
    Mar 2021
    Posts
    2

    Default

    Thanks a ton for your help gents! After spending a bit more time inspecting the underside if the dash, I did find a loose wire. After tightening things up, the blower turned right on. Thanks again guys!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •