Results 1 to 6 of 6
  1. #1
    Join Date
    Sep 2016
    Posts
    5

    Default "Check Trans" message on dash

    I have a 2007 Sunsport with the 325 Indmar with about 500 hours. On the center digital screen, at launch, I get a "check trans" message. The fluid has been changed, and is at the level as prescribed by the sticky post in this forum. There is not a smell, performance issue, sound, etc. Everything is normal.

    This only happens upon launch, when passing about 1500 rpm's. I can hit the "enter" button to acknowledge the message, and it will not come back until I slow back to idle, and take off again.

    I can't tell that anything is wrong. Any ideas on something else to check?

  2. #2
    Join Date
    Sep 2016
    Posts
    5

    Default

    As far as I can tell, there is only a temp sensor on the transmission. I'm still looking around to confirm. If there is only a temp sensor, and the "check trans" message comes up, even before the engine is warm (ie pulling away from the dock after starting), then I may just have a bad temp sensor. I'm hoping that is all it is as it is only about $20 for the sensor.

  3. #3
    Join Date
    Aug 2009
    Location
    London, Ontario, Canada
    Posts
    1,180

    Default

    Please let us know if this is what happened
    2009 21v Worlds 340 Cat
    run your engine after you change the oil
    Doug

  4. #4

    Default

    There is a trans temp switch, not a temp sensor. On 2006 and newer models, the switch should be closed (continuity through switch) when trans temp is below 193F and open (no continuity) when temp is above 193F. On 2005 and older models the switch is open(no continuity through switch) when the trans temp is below 193F and closed (continuity through switch) above 193F.
    Last edited by Engine Nut; 07-19-2019 at 02:20 PM.
    Larry Engelbert
    Indmar Marine Engines

  5. #5

    Default

    This is exactly what happened to me. 2007 launch 20 SSV with 325 Indmar. The shop spent 2 months troubleshooting and I had a bad ecm and a bad wiring harness. The order for the wiring harness was put in last week, so I’m still waiting on that. All in all, I’m about $2k in, missed most of the season, and still don’t have my boat back. Hopefully you have better luck.

  6. #6
    Join Date
    Apr 2021
    Posts
    1

    Default

    Hey there - what ended up being the problem with this? I just bought a 2007 Launch 24 SSV and a couple trips round the lake I got the Check Trans error on the dash display. Everything else feels and sound and runs great. What should I be looking for? Did you correct the issue or at least get to the bottom of it?
    Rusty Allen
    2007 Supra Launch 24SSV

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •