Results 1 to 5 of 5
  1. #1
    Join Date
    Sep 2021
    Location
    White Bear Lake
    Posts
    5

    Default 2005 Supra Launch not holding speed

    Hi guys, new member here and first post, we purchased a 2005 Supra Launch 21V for our winter project boat and will be filming youtube videos and stuff as we tackle projects, but first question i have is the speed control appears to work, beeps and all, but speed just keeps increasing,

    Anyone have any recommendations on what to check first?

    Thanks!

  2. #2
    Join Date
    Aug 2019
    Location
    St. Louis , MO
    Posts
    134

    Default

    [QUOTE=SWELLWakesurf;139232]Hi guys, new member here and first post, we purchased a 2005 Supra Launch 21V for our winter project boat and will be filming youtube videos and stuff as we tackle projects, but first question i have is the speed control appears to work, beeps and all, but speed just keeps increasing,

    Anyone have any recommendations on what to check first?

    Thanks![/QUOTE
    Assuming you have Perfect Pass, I would look up troubleshooting on their website. You can also contact them as they are pretty helpful over the phone. When you first turn the key on (but don't start the engine) the autowind feature activates on the controller on top of the engine. Your paddlewheel sensor may be sticking or going bad.

    Check out this link:
    http://perfectpass.com/?q=troubleshooting

  3. #3
    Join Date
    Sep 2021
    Location
    White Bear Lake
    Posts
    5

    Default

    Thank you!

  4. #4
    Join Date
    Aug 2019
    Location
    St. Louis , MO
    Posts
    134

    Default

    Quote Originally Posted by SWELLWakesurf View Post
    Thank you!
    I just watched the troubleshooting guide, and it could be a weak/missing, broken or sticking throttle return spring. Good luck.

  5. #5
    Join Date
    Sep 2020
    Location
    Nebraska
    Posts
    13

    Default

    Quote Originally Posted by SWELLWakesurf View Post
    Hi guys, new member here and first post, we purchased a 2005 Supra Launch 21V for our winter project boat and will be filming youtube videos and stuff as we tackle projects, but first question i have is the speed control appears to work, beeps and all, but speed just keeps increasing,

    Anyone have any recommendations on what to check first?

    Thanks!
    Hey Swell,

    Love your H3xPlus on my 06 Supra 24V. I just upgraded up the perfect from the stock paddle wheel to the perfect pass Stargazer system this summer. Huge improvement! For wakeboarding the paddle wheel was fine, but for surfing it would never settle and would range from 11.2 +- 3 mph. It was a easy install as well. Look forward to seeing your project videos online.
    06 Supra Sunsport 24V w/325 MPI Assault

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •