Results 1 to 5 of 5
  1. #1
    Join Date
    May 2020
    Posts
    19

    Default Dash gauge’s not turning on 2008 launch

    When I turn the key to the on position I have zero gauges turning on. The boat will start the fuel pump and turn over fine. The boat will also run fine but no gauges. This started happening intermittently but is now full time. I have looked for a fuse with no luck. Does anyone have any recommendations on where I should start? ( I have replaced the ignition key module already)


    Sent from my iPhone using Tapatalk

  2. #2
    Join Date
    Dec 2015
    Location
    Lake Nottely, Blairsville, GA
    Posts
    1,200

    Default

    Quote Originally Posted by Evan46 View Post
    When I turn the key to the on position I have zero gauges turning on. The boat will start the fuel pump and turn over fine. The boat will also run fine but no gauges. This started happening intermittently but is now full time. I have looked for a fuse with no luck. Does anyone have any recommendations on where I should start? ( I have replaced the ignition key module already)


    Sent from my iPhone using Tapatalk
    Is there a circuit breaker before the fuse block? My 2012 has a breaker to cut all electronics next to battery cut off switch.

    1983 Supra Rider aka Mischief IV
    1983 Supra Beast
    1985 Supra Rider
    1986 Supra Sunsport Skier
    1987 Supra Marauder
    1991 Supra Comp ts6m
    2012 Supra Sunsport 242

  3. #3
    Join Date
    May 2020
    Posts
    19

    Default

    I have a complete new mmdc, gauges, and wire harness. I am trying to replace but 4 of the five gauges have the same wire colors and pin set up. How do I find out which cluster goes to which gauge?


    Sent from my iPhone using Tapatalk

  4. #4
    Join Date
    Jun 2012
    Location
    Knoxville TN
    Posts
    1,383

    Default

    Dealer might be able to help you out on their computer with online diagrams.
    2018 Supra SL400

  5. #5
    Join Date
    May 2019
    Location
    Arizona
    Posts
    188

    Default

    Check power at the ignition switch on the accessory side as well


    Sent from my iPhone using Tapatalk

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •