Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2022
    Posts
    1

    Default 2007 supra launch no fuel

    Hi everyone,

    I have a 2007 supra launch with the 325 assult. i have no fuel going to the engine and have found no power on the fuel pumps fuses( the two 20 amp) on the engine block by ecu. i have check all other breakers and fuses and they are all ok. Does anyone know what powers those fuses or have a schematic for this boat? thanks in advance for the help.

  2. #2
    Join Date
    May 2019
    Location
    Arizona
    Posts
    197

    Default

    Quote Originally Posted by N8ng1313 View Post
    Hi everyone,

    I have a 2007 supra launch with the 325 assult. i have no fuel going to the engine and have found no power on the fuel pumps fuses( the two 20 amp) on the engine block by ecu. i have check all other breakers and fuses and they are all ok. Does anyone know what powers those fuses or have a schematic for this boat? thanks in advance for the help.
    Check the tethered kill switch


    Sent from my iPhone using Tapatalk

  3. #3
    Join Date
    Jun 2012
    Location
    Knoxville TN
    Posts
    1,415

    Default

    Quote Originally Posted by N8ng1313 View Post
    Hi everyone,

    I have a 2007 supra launch with the 325 assult. i have no fuel going to the engine and have found no power on the fuel pumps fuses( the two 20 amp) on the engine block by ecu. i have check all other breakers and fuses and they are all ok. Does anyone know what powers those fuses or have a schematic for this boat? thanks in advance for the help.
    Not aware of schematic existing.

    Kill switch is the first thing to check - remove and insert it back into position.
    2018 Supra SL400

  4. #4
    Join Date
    Aug 2019
    Location
    St. Louis , MO
    Posts
    135

    Default

    Quote Originally Posted by N8ng1313 View Post
    Hi everyone,

    I have a 2007 supra launch with the 325 assult. i have no fuel going to the engine and have found no power on the fuel pumps fuses( the two 20 amp) on the engine block by ecu. i have check all other breakers and fuses and they are all ok. Does anyone know what powers those fuses or have a schematic for this boat? thanks in advance for the help.
    Check the fuel pump relay on the rear of the engine. Should be other similar relays such as the starter relay next to it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •